Циклы с условием. Страница 3

Планирование уроков на учебный год (по учебнику К.Ю. Полякова, Е.А. Еремина, углубленный уровень)


Урок 48
§37. Циклы с условием



Содержание урока

Что такое цикл с условием?

Логические команды Робота

Вложенные циклы

Выводы. Интеллект-карта

Вопросы и задания

Практическая работа № 28 «Циклы с условием»


Вложенные циклы


Задача. Роботу нужно закрасить 4 ряда клеток между двумя стенами, причём расстояние между этими стенами неизвестно (рис. 6.33).

Рис. 6.33

Рис. 6.33

Выделите в этой задаче две подзадачи, которые нужно выполнить несколько раз. Назовите их Ряд и Переход. Опишите в тетради эти подзадачи в словесном виде.

Найдите ошибку в решении подзадачи Ряд:

нц пока справа свободно

вправо

закрасить

кц

Какого типа эта ошибка? Как её исправить?

Найдите и исправьте логическую ошибку в решении подзадачи

Переход:

вниз

нц пока слева свободно

влево

кц

Подсказка: эта ошибка проявляется только после обработки последнего ряда.

Составьте полную программу решения задачи, показанной на рис. 6.33, и проверьте её работу на компьютере.

Теперь ещё усложним задачу — пусть рядов будет не четыре, а неизвестно сколько, причём эти ряды будут заканчиваться там, где заканчивается стена слева. Обратите внимание, что одна из этого множества задач — задача с четырьмя рядами, которую мы уже решили.

Можно ли для новой задачи использовать цикл «N раз»? Почему?

Какой цикл вы предлагаете использовать? Каково должно быть условие остановки цикла? Условие продолжения цикла?

Напишите программу, которая работает для любого количества рядов, и проверьте её на компьютере. Будет ли она правильно работать для задачи, показанной на рис. 6.33?

Следующая страница Выводы. Интеллект-карта



Cкачать материалы урока







Наверх