§ 21. Массивы | Ввод массива с клавиатуры

Планирование уроков на учебный год (по учебнику К.Ю. Полякова, Е.А. Еремина, углубленный уровень)


Уроки 42 - 43
§21. Массивы




Содержание урока

Что такое массив?

Перебор элементов массива

Вывод массива

Ввод массива с клавиатуры

Заполнение массива случайными числами

Массивы в других языках программирования

Выводы. Интеллект-карта

Вопросы и задания

Практическая работа № 20 «Заполнение массивов»

Практическая работа № 21 «Перебор элементов массива»


Ввод массива с клавиатуры


Иногда небольшие массивы вводятся с клавиатуры. В простейшем случае мы просто строим цикл, который выполняет оператор ввода для каждого элемента массива:

нц для i от 1 до N               for i:=l to N do

ввод A[i]               read(A[i]);

КЦ


При этом пользователь вводит данные «вслепую», т. е. программа не подсказывает ему, значение какого элемента вводится в данный момент. Значительно удобнее, если перед вводом появляется сообщение с подсказкой:

нц для i от 1 до N               for i:=l to N do begin

вывод 'A[',i,']='               write('A[',i,']=?);

ввод A[i]               read(A[i])

кц               end;


В этом примере перед вводом очередного элемента массива на экран выводится подсказка. Например, после ввода второго элемента будет выведено А[3]= — программа будет ждать ввода третьего элемента.

Следующая страница Заполнение массива случайными числами



Cкачать материалы урока








Наверх