Самостоятельная работа № 19 «Цикл с заданным числом повторений»

Планирование уроков на учебный год (ФГОС)


Самостоятельная работа № 19 «Цикл с заданным числом повторений»




Вариант 1


1. Черепахе был дан для исполнения следующий алгоритм:

Повтори 20 [Направо 45 Вперёд 20 Направо 45]


Какая фигура появится на экране?

2. Чертёжнику был дан для исполнения следующий алгоритм:

Повтори 20 раз

Сместиться на (-3, -4)

Сместиться на (3, 3)

Сместиться на (1, -2)

Конец

Какую единственную команду можно выполнить Чертёжнику, чтобы оказаться в той же точке, в которой он находится после исполнения этого алгоритма?

3. Определите значение переменной S после выполнения фрагмента алгоритма:

4. Дополнительное задание. Для исполнителя Чертёжник, начальное положение которого указано карандашиком, разработайте алгоритм изображения следующего рисунка:

5. Дополнительное задание. Для исполнителя Робот, начальное положение которого отмечено ромбиком, разработайте алгоритм изображения следующего узора:

6. Дополнительное задание. Разработайте алгоритм определения, на сколько сумма первых десяти чётных чисел меньше их произведения.

Вариант 2


1. Черепахе был дан для исполнения следующий алгоритм:

Повтори 8 [Вперёд 20 Направо 90 Вперёд 20]


Какая фигура появится на экране?

2. Чертёжнику был дан для исполнения следующий алгоритм:

Повтори 8 раз

Сместиться на (1, 3)

Сместиться на (-2, -5)

Конец

Сместиться на (40, 18)


Какую команду надо выполнить Чертёжнику, чтобы вернуться в исходную точку, из которой он начал движение?

3. Определите значение переменной Р после выполнения фрагмента алгоритма:

4. Дополнительное задание. Для исполнителя Чертёжник, начальное положение которого указано карандашиком, разработайте алгоритм изображения следующего рисунка:

5. Дополнительное задание. Для исполнителя Робот, начальное положение которого отмечено ромбиком, разработайте алгоритм изображения следующего узора:

6. Дополнительное задание. Разработайте алгоритм сравнения (больше, меньше) произведения и суммы чисел





Наверх