Технология накопления данных и их обработки в excel | Создание форм для ответов


Планирование уроков на учебный год


Урок 54
Практикум
Технология накопления данных и их обработки в Excel



Выполнив практическую работу, вы научитесь:

- использовать формы для внесения данных в таблицу;
- работать с несколькими страницами книги;
- вводить, накапливать и обрабатывать данные.

Задание 5.12. Создание форм для ответов



Создание форм с ответами типа Да/Нет

1. Отобразите на экране панель инструментов Формы, выбрав в меню команду Вид ► Панели инструментов ► Формы.

2. Выберите форму Флажок и прорисуйте ее после второго вопроса, закрыв ячейку Е5.

3. Щелкните на форме правой кнопкой мыши и выберите в контекстном меню команду Формат объекта.

4. В появившемся окне на вкладке Цвета и линии установите нужные параметры заливки и границ. На вкладке Элемент управления установите флажок Объемное затенение.

5. Замените стандартное название Флажок 1 на Да/Нет.

6. Щелчком правой кнопки выделите форму и скопируйте ее.

7. Вставьте копию после третьего вопроса, закрыв ячейку Н5.

Настройка форм

1. Щелкните на первой форме правой кнопкой мыши и выберите в контекстном меню Формат объекта.

2. В появившемся окне на вкладке Элемент управления щелкните в строке Связь с ячейкой и затем на ячейке Е5 в таблице. Закройте окно, нажав кнопку ОК.

3. Таким же образом установите связь второй формы с ячейкой Н5.

Создание форм для выбора из списка

1. Отобразите на экране панель инструментов Формы, выбрав в меню команду Вид ► Панели инструментов ► Формы.

2. Выберите форму Поле со списком и прорисуйте ее под четвертым вопросом (см. рис. 5.5).

3. Щелкните на форме правой кнопкой мыши и выберите в контекстном меню команду Формат объекта.

4. В появившемся окне на вкладке Элемент управления установите флажок Объемное затенение и задайте следующие параметры:

✔ в строке Формировать список по диапазону при помощи мыши укажите диапазон для первого списка — адреса ячеек 01:07;
✔ в строке Связь с ячейкой щелчком мыши укажите ячейку, в которую будет помещен, ответ — В8;
✔ укажите количество строк в первом списке — 7. Нажмите кнопку 0К для сохранения настроек.

5. Таким же образом оформите поля со списками для пятого, шестого и седьмого вопросов, связав формы с ячейками Н8, Е11 и Е14 соответственно.

Обработка результатов тестирования


Задание 5.13. Обращение к тестируемому


Область результатов тестирования располагается там, куда ведет гиперссылка в конце теста, например в ячейках А46:А49.

В ячейку А46 заносится обращение к человеку по имени, указанному отвечающим. Имя берется из ячейки с ответом на первый вопрос (G3):

=СЦЕПИТЬ("Уважаемый потенциальный бизнесмен ,,;$G$3;"!").

Задание 5.14. Формирование блока выводов


1. В ячейку А47 заносится один из заранее занесенных в ячейки VI и V2 ответов:

✔ в ячейке VI — «У тебя хорошие предпосылки для занятия бизнесом»;
✔ в ячейке V2 — «У тебя не самые удачные предпосылки для занятия бизнесом».

Выбор результата, который появится в ячейке А47, осуществляется по такому правилу: если человек любит работать или его родители являются бизнесменами или высокопоставленными чиновниками, в ячейку А47 заносится ответ VI, в противном случае — ответ V2.

Формула на языке Excel будет иметь следующий вид:

=E01M(HflM($E$5;$B$8<4);$V$l;$V$2).

2. Для записи в ячейку А48 должны быть подготовлены три варианта ответов:

✔ в ячейке V3 — *Ты обладаешь деловой хваткой ч хорошо соображаешь!»
✔ в ячейке V4 — «Твои способности к бизнесу никуда не годятся!»
✔ в ячейке V5 — «Способности у тебя средние, поэтому придется много трудиться!»

3. В ячейке V7 анализируются ответы на пятый, шестой и седьмой вопросы:

=СУММ(Н8;Е11;Е14)).

Если сумма маленькая (<5), выбирается первый ответ, если сумма большая (от 8 до 10, то есть >7), выбирается второй ответ, в противном случае — третий ответ:

=E01H(V7<5;V3;E01H(V7>7;V4;V5)).

4. И наконец, в ячейку А49, в зависимости от ответа на третий вопрос, заносится первая или вторая заключительная фраза:

=ЕСЛИ(Н5;"Ты можешь проспать свою удачу!";"Умеренный сон необходим организму!").

Контрольные вопросы


1. Для чего используются формы в электронных таблицах?

2. Как вызвать набор форм?

3. Какие состояния может принимать форма Флажок?

4. Форма Флажок связана с ячейкой А10. Что появится в ячейке А10, если флажок установлен?

5. Где хранится содержимое списка для формы Поле со списком?

6. Форма Поле со списком связана с ячейкой С8. Что появится в ячейке С8 при выборе второго ответа из списка?

7. Что такое гиперссылка? Можно ли организовать гиперссылки в электронных таблицах?

8. Как использовать ячейку электронной таблицы в качестве кнопки для перехода в другое место таблицы?





Наверх