Алгоритмы с повторениями для исполнителя Чертёжник | Урок 31. Часть 2

Материалы к урокам 6 класса (ФГОС)


Урок 31
Алгоритмы с повторениями для исполнителя Чертёжник
Работа в среде исполнителя Чертёжник



Содержание урока

Презентация «Управление исполнителем Чертежник»

Цикл ПОВТОРИТЬ n РАЗ

Вопросы и задания

Плакат «Исполнитель»

Компьютерный практикум. Ресурсы ЕК ЦОР. Система КуМир

Компьютерный практикум. Ресурсы ЕК ЦОР. Задания 1 - 2

Компьютерный практикум. Ресурсы ЕК ЦОР. Задания 3 - 4


Цикл ПОВТОРИТЬ n РАЗ


Ключевые слова:
• исполнитель Чертёжник
• абсолютное смещение
• относительное смещение
• вспомогательный алгоритм
• основной алгоритм
• цикл n раз

При составлении алгоритмов довольно часто встречаются случаи, когда некоторую последовательность команд нужно выполнять несколько раз подряд. Для упрощения записи алгоритма в таких случаях можно использовать специальную конструкцию повторения.

Например, программу рисования ряда из пяти ромбов (рис. 71) с помощью конструкции повторения можно записать так:
использовать Чертежник
алг ряд ромбов
нач
     сместиться в точку (1,2)
     нц 5 раз
          опустить перо
          сместиться на вектор (1, 2)
          сместиться на вектор (1, -2)
          сместиться на вектор (-1, -2)
          сместиться на вектор (-1, 2)
          поднять перо
          сместиться на вектор (3, 0)

     кц
кон

image

Рисование ромба можно оформить в виде вспомогательного алгоритма:
алг ромб
нач
     сместиться на вектор (1, 2)
     сместиться на вектор (1, -2)
     сместиться на вектор (-1, -2)
     сместиться на вектор (-1, 2)
кон

Тогда основной алгоритм будет выглядеть так:
использовать Чертежник
алг ряд ромбов_1
нач
     сместиться в точку (1,2)
     нц 5 раз
          опустить перо
          ромб
          поднять перо
          сместиться на вектор (3, 0)

     кц
кон

В общем виде конструкция повторения записывается так:

нц <число повторений> раз

<тело цикла>

кц

Служебные слова нц и кц пишутся одно под другим. Чуть правее между ними записывается повторяющаяся последовательность команд (тело цикла). Число повторений — произвольное целое число. Именно столько раз при выполнении алгоритма будут повторены команды, образующие тело цикла.

Предложите вариант решения задачи о почтовом индексе Красноярска с использованием конструкции повторения.

Можно ли обойтись без вспомогательного алгоритма в следующих ситуациях (рис. 72)?

image

Следующая страница Вопросы и задания



Cкачать материалы урока





Наверх