§36. Переменные. Страница 1 (68 часов в уч. год)

Планирование уроков на учебный год (по учебнику К.Ю. Полякова, Е.А. Еремина, углубленный уровень)


Уроки 46 - 47
§36. Переменные



Содержание урока

Зачем нужны переменные?

Процедуры с параметрами

Выводы. Интеллект-карта

Вопросы и задания

Практическая работа № 26 «Переменные»

Практическая работа № 27 «Процедуры с параметрами»


Зачем нужны переменные?


Ключевые слова:

• переменная	
• присваивание	
• объявление переменной
• процедура
• параметр

Попробуем решить задачу, показанную на рис. 6.26.

Сравните эту задачу с задачей, показанной на рис. 6.25. Чем они различаются?

Рис. 6.26

Рис. 6.26

Длины всех рядов тут разные: первый горизонтальный ряд состоит из двух клеток, а длина каждого следующего на одну клетку больше, чем предыдущего.

Обозначим длину очередного ряда буквой N. Тогда алгоритм закраски очередного ряда и возврата к началу следующего ряда выглядит так:

нц N раз

вправо; закрасить

кц

вниз

нц N раз влево кц


Величина N должна изменяться во время работы программы. Как вы уже знаете, такая величина называется переменной.

Каково начальное значение переменной N? Как она должна изменяться при переходе к следующему ряду?

До начала основного цикла нужно присвоить этой переменной значение 2 (это длина верхнего ряда):

N: =2

Символы «:=» — это команда (оператор) присваивания, она присваивает переменной N значение, которое записано в правой части.

После обработки очередного ряда и возврата назад нужно увеличить значение N на 1, т. е. заменить N на N + 1. Для этого тоже используется оператор присваивания:

N: =N+1

В результате получаем такую программу с вложенными циклами:

цел N

N: =2

нц 4 раз

нц N раз

вправо; закрасить

кц

вниз

нц N раз влево кц

N:=N+1

кц

Строка

цел N


называется объявлением переменной. Этой командой мы сказали, что в программе будет использована переменная, которая имеет имя N и может принимать только целочисленные значения (служебное слово цел).

Зачем нужно объявление переменной? При объявлении мы определяем:

• какие значения может принимать эта переменная (целые числа, десятичные дроби, строки символов и др.);
• какие операции можно выполнять с переменной;
• сколько места в памяти компьютера нужно выделить для хранения значения.

В некоторых языках программирования, например в языке Python, объявлять переменные не нужно. С одной стороны, это облегчает составление программы, но с другой — может привести к ошибкам, которые очень сложно обнаружить.

Следующая страница Процедуры с параметрами



Cкачать материалы урока







Наверх