§27. Обработка больших массивов данных | Использование вспомогательных столбцов (informatika_09_34_pol)

Планирование уроков на учебный год (по учебнику К.Ю. Полякова, Е.А. Еремина, базовый уровень)


Урок 25
§27. Обработка больших массивов данных



Содержание урока

Выделение диапазонов

Использование вспомогательных столбцов

Стандартные функции

Работа с листами

Выводы

Вопросы и задания

Практическая работа №28 «Обработка больших массивов данных»

Практическая работа № 28-а «Обработка больших массивов данных»


Использование вспомогательных столбцов


Задача 1. В большой таблице записаны данные участников спортивных соревнований: фамилия, год рождения и вес. Требуется найти количество спортсменов, которые родились в 2004 году. Выполнять сортировку не разрешается.

Один из способов решения этой задачи — добавить в таблицу вспомогательный столбец, в котором напротив каждого участника будет записана единица, если его год рождения равен 2004, или 0, если не равен (рис. 5.10).

Рис. 5.10

Рис. 5.10

Используя материал предыдущего параграфа, запишите формулу, которую нужно добавить в ячейку D2. Предложите два варианта решения задачи.

Формулу из D2 нужно скопировать во все ячейки столбца D. Напомним, что для такого копирования достаточно выполнить двойной щелчок мышью на маркере заполнения выделенной верхней ячейки с формулой.

Теперь количество участников 2004 года рождения находится как сумма значений в столбце D (функция SUM или СУММ). Если в таблице 1000 строк (со 2-й по 1001-ю), формула запишется так:

=SUM(D2:D1001                  =СУММ(D2:D1001)


Задача 2. Для таблицы из задачи 1 требуется найти средний вес тех, кто родился в 2004 году.

Здесь тоже можно использовать вспомогательный столбец. Выведем в нём вес участника, если год рождения равен 2004, или пустую строку (""), если год рождения другой (рис. 5.11).

Рис. 5.11

Рис. 5.11

Используя материал предыдущего параграфа, запишите формулу, которую нужно добавить в ячейку D2. Предложите два варианта решения задачи.

После этого остаётся подсчитать среднее значение ячеек столбца D с помощью функции AVERAGE (СРЗНАЧ), например:

=AVERAGE(D2:D1001)                  =CP3HAЧ(D2:D1001)


Эта функция вычисляет среднее только по тем ячейкам, в которых содержится числовое значение, пустые ячейки не учитываются.

Следующая страница Стандартные функции



Cкачать материалы урока







Наверх