Абсолютная и относительная адресация. Понятие диапазона. Встроенные функции. Сортировка таблицы и таблиц. Использование встроенных математических и статистических функций | Сортировка таблицы

Планирование уроков на учебный год


Урок 30
Абсолютная и относительная адресация
Понятие диапазона. Встроенные функции. Сортировка таблицы и таблиц
Использование встроенных математических и статистических функций




Содержание урока

Абсолютная и относительная адресация

Работа с диапазонами

Принцип относительной адресации

Сортировка таблицы

Вопросы и задания

Практическое задание №15


Сортировка таблицы


Допустим, владелец торгового павильона хочет узнать, какие товары пользуются наибольшим спросом. Для этого достаточно упорядочить строки таблицы по убыванию чисел в столбце «Продано». Большинство табличных процессоров позволяет производить сортировку (упорядочение) таблицы по какому-либо признаку. Для нашего примера формируется команда такого вида:

СОРТИРОВАТЬ СТОЛБЕЦ D ПО УБЫВАНИЮ

Применение этой команды к табл. 4.5 в режиме отображения значений даст результат, показанный в табл. 4.7.

Отсюда видно, что наибольшим спросом пользуется йогурт, а меньше всего покупают сливки.

Эта же таблица в режиме отображения формул табл. 4.8.

Таблица 4.7. Результат сортировки таблицы по столбцу «Продано»

A B C D E F
1 Продукт Цена Поставлено Продано Осталось Выручка
2 Йогурт 5,4 250 225 25 1215
3 Творог 18,5 125 110 15 2035
4 Молоко 20 100 100 0 2000
5 Сметана 10,2 85 70 15 714
6 Сливки 15,2 50 45 5 684
7         Всего: 6648

Таблица 4.8. Отсортированная таблица в режиме отображения формул


A B C D E F
1 Продукт Цена Поставлено Продано Осталось Выручка
2 Йогурт 5,4 250 225 =C2-D2 =B2*D2
3 Творог 18,5 125 110 =C3-D3 =B3*D3
4 Молоко 20 100 100 =C4-D4 =B4*D4
5 Сметана 10,2 85 70 =C5-D5 =B5*D5
6 Сливки 15,2 50 45 =C6-D6 =B6*D6
7         Всего: =СУММ(F2:F6)

Снова сработал принцип относительной адресации. Формулы изменились в соответствии с изменением места расположения строк.


Следующая страница Вопросы и задания









Наверх