Деловая графика. Логические операции и условная функция. Абсолютная адресация. Функция времени. Построение графиков и диаграмм. Использование логических функций и условной функции. Использование абсолютной адресации | Графические возможности табличного процессора

Планирование уроков на учебный год


Урок 31
Деловая графика. Логические операции и условная функция
Абсолютная адресация. Функция времени. Построение графиков и диаграмм
Использование логических функций и условной функции. Использование абсолютной адресации



Содержание урока

Деловая графика

Деловая графика. Условная функция

Деловая графика. Вопросы и задания

Логические функции и абсолютные адреса. Запись и выполнение логических функций

Логические функции и абсолютные адреса. Функция времени

Логические функции и абсолютные адреса. Вопросы и задания

Практическое задание №16


Деловая графика. Условная функция


Графические возможности табличного процессора


Замечательным свойством электронных таблиц является возможность графического представления числовой информации содержащейся в таблице. Для этого существует специальный графический режим работы табличного процессора. Графики придают наглядность числовым зависимостям.

Типы диаграмм


Табличные процессоры дают возможность получать самые различные формы диаграмм и графиков. Ниже на рисунках показаны два типа диаграмм: круговая на рис. 4.1 и столбчатая на рис. 4.2. Исходные данные для этих диаграмм извлекаются из одинаковых диапазонов ячеек А2:А6 и D2:D6 таблиц из предыдущего параграфа. Первый диапазон содержит названия продуктов, второй — количество проданных единиц каждого продукта. Из диаграмм сразу видно, что наибольшим спросом у покупателей пользуется йогурт.

Круговую диаграмму обычно используют в тех случаях, когда нужно показать, какую часть от целого (круга) составляют отдельные величины (секторы). Столбчатая диаграмма (гистограмма) позволяет наглядно сопоставить между собой отдельные величины.

image image

Рис. 4.1. Круговая диаграмма

Рис. 4.2. Столбчатая диаграмма (гистограмма)

Условная функция


Продолжим обсуждение задачи об учете продажи молочных продуктов в торговом павильоне. В случае если тот или иной продукт продан полностью, необходимо организовать его подвоз в торговый павильон. Чтобы отразить это в электронной таблице, добавим в табл. 4.8 новый столбец с названием «Подвоз». В ячейках этого столбца будет высвечиваться слово «Да», если подвоз соответствующего продукта необходим, и «Нет», если продукт подвозить не надо. Разумеется, значения «Да» или «Нет» табличный процессор должен определить сам автоматически.

Для решения задачи воспользуемся условной функцией. Общий вид условной функции следующий:

ЕСЛИ(<условие>; <выражение 1>; <выражение 2>)

<Условие> — это логическое выражение, которое может принимать значение ИСТИНА или ЛОЖЬ. С логическими выражениями вы познакомились в главе о базах данных. В электронных таблицах они имеют тот же смысл. <Выражение 1> и <выражение 2> могут быть числами, формулами или текстами.

Условная функция, записанная в ячейку таблицы, выполняется так: если <условие> истинно, то значение данной ячейки определяет <выражение 1>, в противном случае — <выражение 2>.

В нашем случае условие означает проверку на равенство нулю количества оставшегося продукта. В качестве выражений 1 и 2 выступают текстовые константы «Да» и «Нет».

После внесенных изменений учетный документ примет вид, представленный в табл. 4.9 (в режиме отображения формул) и в табл. 4.10 (в режиме отображения значений).

Таблица 4.9. Таблица с условной функцией в режиме отображения формул


A B C D E F G
1 Продукт Цена Поставлено Продано Осталось Выручка Подвоз
2 Йогурт 5,4 250 225 =C2-D2 =B2*D2 =ЕСЛИ(E2=0;"Да";"Нет")
3 Творог 18,5 125 110 =C3-D3 =B3*D3 =ЕСЛИ(E3=0;"Да";"Нет")
4 Молоко 20 100 100 =C4-D4 =B4*D4 =ЕСЛИ(E4=0;"Да";"Нет")
5 Сметана 10,2 85 70 =C5-D5 =B5*D5 =ЕСЛИ(E5=0;"Да";"Нет")
6 Сливки 15,2 50 45 =C6-D6 =B6*D6 =ЕСЛИ(E6=0;"Да";"Нет")
7         Всего: =СУММ(F2:F6)  


Таблица 4.10. Таблица с условной функцией в режиме отображения значений


A B C D E F G
1 Продукт Цена Поставлено Продано Осталось Выручка Подвоз
2 Йогурт 5,4 250 225 25 1215 Нет
3 Творог 18,5 125 110 15 2035 Нет
4 Молоко 20 100 100 0 2000 Да
5 Сметана 10,2 85 70 15 714 Нет
6 Сливки 15,2 50 45 5 684 Нет
7         Всего: 6648  


Следующая страница Деловая графика. Вопросы и задания









Наверх