Деловая графика. Логические операции и условная функция. Абсолютная адресация. Построение графиков и диаграмм. Использование логических функций и условной функции. Использование абсолютной адресации | Функция времени

Планирование уроков на учебный год


Урок 31
Деловая графика. Логические операции и условная функция
Абсолютная адресация. Функция времени. Построение графиков и диаграмм
Использование логических функций и условной функции. Использование абсолютной адресации



Содержание урока

Деловая графика

Деловая графика. Условная функция

Деловая графика. Вопросы и задания

Логические функции и абсолютные адреса. Запись и выполнение логических функций

Логические функции и абсолютные адреса. Функция времени

Логические функции и абсолютные адреса. Вопросы и задания

Практическое задание №16


Логические функции и абсолютные адреса. Функция времени


Осталось обсудить формулу, вычисляющую количество времени, оставшееся до конца рабочего дня. Можно, посмотрев на часы, вручную вставить это время в ячейку Е9. Но в современных табличных процессорах существуют специальные функции (функции времени), позволяющие получить текущее время. Это возможно благодаря тому, что в состав аппаратной части компьютеров входит таймер — внутренние часы компьютера. Если рабочий день заканчивается в 20 часов, то формула должна быть такой: 20 - ТЕКУЩИЙ ЧАС. Пусть, например, функция определения текущего часа записывается так: ЧАС(ТДАТА()).

После внесения изменений таблица в режиме отображения формул примет вид табл. 4.11, а в режиме отображения значений — табл. 4.12.

Таблица 4.11. Таблица в режиме отображения формул


A B C D E F G
1 Продукт Цена Поставлено Продано Осталось Выручка Подвоз
2 Йогурт 5,4 250 225 =C2-D2 =B2*D2 =ЕСЛИ(E2=0;"Да";"Нет")
3 Творог 18,5 125 110 =C3-D3 =B3*D3 =ЕСЛИ(E3=0;"Да";"Нет")
4 Молоко 20 100 100 =C4-D4 =B4*D4 =ЕСЛИ(E4=0;"Да";"Нет")
5 Сметана 10,2 85 70 =C5-D5 =B5*D5 =ЕСЛИ(E5=0;"Да";"Нет")
6 Сливки 15,2 50 45 =C6-D6 =B6*D6 =ЕСЛИ(E6=0;"Да";"Нет")
7         Всего: =СУММ(F2:F6)  
8              
9 Осталось до конца дня: =20-ЧАС(ТДАТА()) часа  


Таблица 4.12. Таблица в режиме отображения значений


A B C D E F G
1 Продукт Цена Поставлено Продано Осталось Выручка Подвоз
2 Йогурт 5,4 250 225 25 1215 Нет
3 Творог 18,5 125 110 15 2035 Нет
4 Молоко 20 100 100 0 2000 Да
5 Сметана 10,2 85 70 15 714 Нет
6 Сливки 15,2 50 45 5 684 Нет
7         Всего: 6648  
8              
9 Осталось до конца дня: 2 часа  

Обратите внимание на то, что из табл. 4.12 следует, что молоко уже закончилось, но подвозить его не следует, так как до конца рабочего дня осталось 2 часа.


Следующая страница Логические функции и абсолютные адреса. Вопросы и задания









Наверх