§26. Условные вычисления | Функция ЕСЛИ (informatika_09_34_pol)

Планирование уроков на учебный год (по учебнику К.Ю. Полякова, Е.А. Еремина, базовый уровень)


Урок 24
§26. Условные вычисления



Содержание урока

Функция ЕСЛИ

Вложенные вызовы ЕСЛИ

Сложные условия (И, ИЛИ, НЕ)

Выводы

Практическая работа №24 «Стандартные функции»

Практическая работа №25 «Таблицы истинности»

Практическая работа №26 «Условные вычисления»

Практическая работа № 26-а «Условные вычисления»

Практическая работа №27 «Сложные условия»


Функция ЕСЛИ


Ключевые слова:

• условные вычисления	
• функция IF (ЕСЛИ)	
• функция NOT (НЕ)
• функция AND (И)
• функция OR (ИЛИ)

Как вы знаете, в программировании важную роль играют условные операторы (ветвления), позволяющие выбирать один из двух (или нескольких) вариантов обработки данных. В табличных процессорах тоже возможны условные вычисления, при которых в ячейку заносится то или иное значение в зависимости от выполнения какого-то условия.

Предположим, что в книжном интернет-магазине «Бука» доставка покупок бесплатна для тех, кто сделал заказ на сумму более 500 рублей, а для остальных доставка стоит 20% от суммы заказа 1) (рис. 5.1).


1) В этой и следующих таблицах результаты вычислений округляются до целых чисел.



Рис. 5.1

Рис. 5.1

Таким образом, есть два варианта вычисления стоимости доставки, поэтому в формулах столбца С нужно использовать ветвление. Алгоритм вычисления значения в ячейке С2 может выглядеть так: «если В2 > 500, то записать в ячейку 0, иначе записать значение В2*0,2». В программе на языке Паскаль мы бы записали:

if В2>500 then

С2 : =0

else С2:=В2 *0.2;


В табличных процессорах для условных вычислений используют функцию IF (ЕСЛИ) 2):

=IF(B2>500;0;B2*0,2)              =ЕСЛИ(В2>500;0;В2*0,2)



2) В программе OpenOffice Calc используются английские названия функций, а в русской версии табличного процессора Microsoft Excel — русские. В тексте приводятся два варианта каждой формулы, из которых вам нужно выбрать тот, который соответствует используемой программе.



У этой функции три аргумента, разделённые точками с запятой:

1) условие (В2>500);
2) значение ячейки в том случае, когда условие истинно (0);
3) значение ячейки в том случае, когда условие ложно (В2*0,2).

Определите значения, которые появятся в ячейках диапазона В2:В6 после ввода формул (рис. 5.2).

Рис. 5.2

Рис. 5.2

В условии можно использовать не только числовые, но и символьные данные. Например, фирма «Салют» в этом месяце проводит рекламную акцию: предоставляет скидку 20% на все товары (рис. 5.3).

Рис. 5.3

Рис. 5.3

В этом случае в ячейку D2 запишем формулу:

=D2="Салют";С2*20%;"")

=ECЛИ(B2=,,Салют";С2*20%;"")


и скопируем её во все ячейки столбца D. Запись «*20%» означает то же самое, что и «*0,2».

Работник получает премию, составляющую 10% от его зарплаты, только тогда, когда на него не поступает жалоб. Какую формулу нужно записать в ячейку D2 (рис. 5.4)?

Рис. 5.4

Рис. 5.4



Следующая страница Вложенные вызовы ЕСЛИ



Cкачать материалы урока







Наверх