§26. Условные вычисления | Вложенные вызовы ЕСЛИ (informatika_09_34_pol)

Планирование уроков на учебный год (по учебнику К.Ю. Полякова, Е.А. Еремина, базовый уровень)


Урок 24
§26. Условные вычисления



Содержание урока

Функция ЕСЛИ

Вложенные вызовы ЕСЛИ

Сложные условия (И, ИЛИ, НЕ)

Выводы

Практическая работа №24 «Стандартные функции»

Практическая работа №25 «Таблицы истинности»

Практическая работа №26 «Условные вычисления»

Практическая работа № 26-а «Условные вычисления»

Практическая работа №27 «Сложные условия»


Вложенные вызовы ЕСЛИ


Второй и третий аргументы функции IF могут содержать вложенные вызовы этой функции. Пусть, например, в книжном интернет-магазине «Бука» (см. задачу в начале параграфа) для заказов стоимостью более 200 рублей (но не более 500) стоимость доставки составляет 10% от суммы:

В табличном процессоре этот алгоритм запишется в виде

=IF(B2>500;0;IF(B2>200;B2*0,1;B2*0,2))

=ЕСЛИ(В2>500;0;ЕСЛИ(В2>200;В2*0,1;В2*0,2))


Фирма «Форсаж» занимается доставкой мебели. Если в доме нет лифта, за подъём берут дополнительную плату 100 рублей, а если вес покупки больше 100 кг, то плата за подъём составляет 200 рублей. Какую формулу нужно записать в ячейку D2 (рис. 5.5)?

Рис. 5.5

Рис. 5.5



Следующая страница Сложные условия (И, ИЛИ, НЕ)



Cкачать материалы урока







Наверх