§26. Условные вычисления | Сложные условия И, ИЛИ, НЕ (informatika_09_34_pol)

Планирование уроков на учебный год (по учебнику К.Ю. Полякова, Е.А. Еремина, базовый уровень)


Урок 24
§26. Условные вычисления



Содержание урока

Функция ЕСЛИ

Вложенные вызовы ЕСЛИ

Сложные условия (И, ИЛИ, НЕ)

Выводы

Практическая работа №24 «Стандартные функции»

Практическая работа №25 «Таблицы истинности»

Практическая работа №26 «Условные вычисления»

Практическая работа № 26-а «Условные вычисления»

Практическая работа №27 «Сложные условия»


Сложные условия (И, ИЛИ, НЕ)


Первый аргумент функции IF (ЕСЛИ) может быть сложным условием, которое строится с помощью функций AND (И) — логическое умножение, OR (ИЛИ) — логическое сложение и NOT (НЕ) — отрицание.

Задача 1. Пусть в примере на рис. 5.1 бесплатная доставка распространяется только на заказы, у которых номер меньше 1500 и сумма больше 500 рублей.

В этом случае в ячейку С2 нужно записать такую формулу:

=IF(AND(A2<1500;B2>500);0;B2*0,2)

=ЕСЛИ(И(А2<1500;В2>500);0;В2*0,2)


Здесь использовано сложное условие AND(A2<1500; В2>500), которое истинно только при одновременном выполнении двух условий: А2<1500 и В2>500. Фирма «Мираж» занимается доставкой питьевой воды. Если в доме нет лифта и заказано более 5 бутылей, то за подъём берут дополнительную плату 20 рублей с каждой бутыли.

Какую формулу нужно записать в ячейку D2 (рис. 5.6)? Предложите несколько вариантов оешения задачи.

Рис. 5.6

Рис. 5.6

Задача 2. На трассе разрешается ехать со скоростью от 40 км/ч до 110 км/ч. Радар записывает скорость проезжающих машин, а видеокамера — их номера. Водителям, которые едут со скоростью, меньшей минимальной или большей максимальной, нужно выписать штраф 500 рублей. Требуется построить электронную таблицу такого вида (рис. 5.7).

Рис. 5.7

Рис. 5.7

Штраф выписывается, когда верно одно из двух условий (скорость меньше 40 км/ч ИЛИ скорость больше 110 км/ч). Формула в ячейке С2 может быть записана так:

=IF(OR(B2<40;B2>110);500;M ")

=ЕСЛИ(ИЛИ(В2<40;В2>110);500;" ")


Компания «Уют» проводит акцию: те, кто купил не меньше 5 стульев или не меньше 2 столов, получают приз. Какую формулу нужно записать в ячейку D2 (рис. 5.8)? Предложите несколько вариантов решения задачи.

Рис. 5.8

Рис. 5.8

Логические функции AND (И) и OR (ИЛИ) могут содержать более двух условий, которые перечисляются через точку с запятой.

Задача 3. На III тур соревнований нужно отобрать участников, которые набрали по сумме двух первых туров не менее 180 баллов или получили 100 баллов хотя бы в одном туре (рис. 5.9).

Рис. 5.9

Рис. 5.9

Формула в ячейке D2 содержит сложное условие, где операция OR (ИЛИ) объединяет три условия:

=IF(OR(B2+C2>=180;B2=100;C2=100);"+";"")

=ЕСЛИ(ИЛИ(В2+С2>=180;В2=100;С2=100);"+";" ")


Функция NOT (НЕ) выполняет логическое отрицание. Она используется на практике довольно редко.

Следующая страница Выводы



Cкачать материалы урока







Наверх